Artboard
Classic Docs
Docs Navigation

Qt

Semaphore supports the following versions of the Qt runtime:

  • 4.8.1
  • 5.4.2
  • 5.5.1

Switching between Qt versions is done through creating an environment variable called QT_SELECT.

The value of this variable can be set to:

  • 48, 4 or qt4 to select version 4.8.1
  • 54, 5 or qt5 to select version 5.4.2
  • 55 or qt55 to select version 5.5.1

The default version is 4.8.1.

If you use the capybara-webkit gem and decide to change the version of Qt, the gem has to be reinstalled. One way to achieve this, is by expiring your project's cache in Project Settings. On the other hand, if you'd like to preserve your cache, please send your request to our support.

Semaphore Docs are open source — Edit on GitHub

Newsletter

Occasional lightweight product and blog updates. Unsubscribe at any time.

2009-2019 © Rendered Text. All rights reserved. Terms of Service, Privacy policy, Security.